1 건의
rake 검색결과

RoR 개발을 할 때 DB Migration을 위해서 만들어진 명령어.


$ rake db:migrate

개발을 하다가 보니 이상한 에러가...



$ rake db:migrate
rake aborted!
You have already activated rake 10.0.3, but your Gemfile requires rake 10.0.2



뭐 때문인가 했더니 일단 에러메세지를 근거로 한다면 현재 rake Gem은  10.0.3 이 활성화 되어있다.


하지만 당신의 Gem은 10.0.2를 필요로 하고있다.


결국 rake Gem의 버젼충돌이라는 소리였습니다.


일단 Gem의 리스트를 봐야겠죠.


$ gem list


를 입력을 하면 현재 깔려있는 List가 나오게 됩니다.


저의 경우

rake (10.0.3, 10.0.2)


로 뜨고 있었습니다.


해결법은 매우 간단합니다.


$ gem uninstall rake –version 10.0.3


일단 현재 제가 쓰고 있는 버젼은 10.0.2 입니다.


다른 버젼을 지우시려면 뒤에 다른 버젼을 집어넣으시면 됩니다.


또한 다른 Gem을 지울 때에도 유용하게 쓸 수 있을 겁니다.


Refer : http://codedecoder.wordpress.com/2012/12/20/bundle-exec-in-rails/



TokenMarket ICO calendar