루비와 레일즈 업데이트 한다고


 gem update 했다가


호환성 문제로 완전 헤맸네요.


가장 큰 건 Capistrano


에서

INFO [34a5e7d4] Running /usr/bin/env bundle install --path /WorkSpace/goodoc/shared/bundle --without development test --deployment --quiet as user@14.63.172.11
DEBUG [34a5e7d4] Command: cd /WorkSpace/goodoc/releases/20150225004205 && ( PATH=/user/.rbenv/versions/2.1.4/lib/ruby/gems:/user/.rbenv/versions/2.1.4/bin:$PATH /usr/bin/env bundle install --path /WorkSpace/goodoc/shared/bundle --without development test --deployment --quiet )
DEBUG [34a5e7d4]     /usr/bin/env:
DEBUG [34a5e7d4]     bundle
DEBUG [34a5e7d4]     : No such file or directory


이걸로 뜨는 것


찾다 찾다 찾은 방법


직접 서버에 들어가서


user@WorkSpace:~# rbenv versions
  2.1.2
* 2.1.4 (set by /user/.rbenv/version)
user@WorkSpace:~# rbenv rehash
user@WorkSpace:~# bundle update rails
rbenv: bundle: command not found

The `bundle' command exists in these Ruby versions:
  2.1.2

user@WorkSpace:~# bundle
rbenv: bundle: command not found

The `bundle' command exists in these Ruby versions:
  2.1.2

user@WorkSpace:~# rbenv version
2.1.4 (set by /user/.rbenv/version)
user@WorkSpace:~#
user@WorkSpace:~# gem install bundler


아무튼 해결


깔끔한 정리는 나중에.

TokenMarket ICO calendar